I think it should run okay, since you already have it installed?

You've probably searched for this yourself, the tech support page says no more FD8 downloads/installations are possible, and also suggests that activation support for FD8 stops in July:

https://finaldraftsupport.force.com/...-8-and-earlier

Which shouldn't stop your FD8 from running. But if anything goes wrong, you'll have to upgrade.

Always backup, backup, backup your files!

-Derek