AW Amazon Store

AW is an Amazon Affiliate

If this site is helpful to you,
Please consider a voluntary subscription to defray ongoing expenses.


paypal subscribe button

How To Support AW

Editing for authors: because every writer needs a good editor.

 

Welcome to the AbsoluteWrite Water Cooler! Please read The Newbie Guide To Absolute Write

Results 1 to 3 of 3

Thread: [IRC] PMs not working? Here is the fix

Threaded View

  1. #1
    Mostly harmless SuperModerator dpaterso's Avatar
    Join Date
    Feb 2005
    Location
    Caledonia
    Posts
    18,631

    [IRC] PMs not working? Here is the fix

    Weirdly, PMs (or DMs or Queries or Private Messages depending on your vocabulary) seem to have defaulted to ignore. This started sometime yesterday (Thursday 31st).

    That is, if you open a PM window with someone, and type a message to them, they may not see your text. (Check your Console tab, you may see errors there confirming this... something like "Message to '[nick]' not delivered: User does not accept private messages.")

    To fix this, y'all have to enter: /umode2 -D

    Not just you, but the person you're sending to also. You may have to communicate this to them in a chat channel. They can't see your PMs!

    And you have to do this every time you sign in, it isn't retained.

    Another bewildering blip brought to you by IRC. Edit 2: Starchat ops said bots were connecting and flooding users with PMs. They changed the default setting to "do not accept PMs" as a defense against this. The recommended command to fix this is /mode urnick -D which I guess works same as /umode2 -D

    Edit: I tried adding the /umode2 -D string to IceChat's Settings > Startup tab so it would run automatically, and ticked the "Auto Perform on Startup" box, but this did not work, dammit. I still had to enter the string manually after starting IceChat.

    Plan B, adding the string to IceChat's AutoPerform command list instead:
    - in the left-hand "servers" column, right-click on the connected server name
    - select Edit Server
    - select the AutoPerform tab
    - type /umode2 -D onto a new line.
    - tick the Enable AutoPerform box if it isn't already ticked.
    - Save this change!
    (AutoPerform tab is where you write helpy used-every-day commands like /join #absolutewrite so they execute automatically upon signing in)

    In Chatzilla, select ChatZilla > Preferences
    - select the connected server
    - select the Lists tab
    - select the Add button
    - type umode2 -D (without the leading / )
    - click on Apply button
    - click on OK button
    (Lists tab is where you add helpy used-every-day commands like join #absolutewrite so they execute automatically upon signing in)

    Thanks to 10trackers for finding the fix.

    -Derek
    Last edited by dpaterso; 02-03-2019 at 08:54 PM.
    Check out Flash Fiction Challenge forum, password = flashed
    New prompt posted every Sunday! Write a flash story in 90 minutes, if you dare!

    AW chat - our IRC chat channel (link to FAQ)
    We also have a Discord channel, check out the FAQ

    derekpaterson.net
    My website!
    | My webcomics!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Custom Search