[IRC] PMs not working? Here is the fix

editing_for_authors
Editing for authors: because every writer needs a good editor.

dpaterso

Also in our Discord and IRC chat channels
Staff member
Super Moderator
Moderator
Super Member
Registered
Joined
Feb 12, 2005
Messages
18,779
Reaction score
4,560
Location
Caledonia
Website
derekpaterson.net
Weirdly, PMs (or DMs or Queries or Private Messages depending on your vocabulary) seem to have defaulted to ignore. This started sometime yesterday (Thursday 31st).

That is, if you open a PM window with someone, and type a message to them, they may not see your text. (Check your Console tab, you may see errors there confirming this... something like "Message to '[nick]' not delivered: User does not accept private messages.")

To fix this, y'all have to enter: /umode2 -D

Not just you, but the person you're sending to also. You may have to communicate this to them in a chat channel. They can't see your PMs!

And you have to do this every time you sign in, it isn't retained.

Another bewildering blip brought to you by IRC. Edit 2: Starchat ops said bots were connecting and flooding users with PMs. They changed the default setting to "do not accept PMs" as a defense against this. The recommended command to fix this is /mode urnick -D which I guess works same as /umode2 -D

Edit: I tried adding the /umode2 -D string to IceChat's Settings > Startup tab so it would run automatically, and ticked the "Auto Perform on Startup" box, but this did not work, dammit. I still had to enter the string manually after starting IceChat.

Plan B, adding the string to IceChat's AutoPerform command list instead:
- in the left-hand "servers" column, right-click on the connected server name
- select Edit Server
- select the AutoPerform tab
- type /umode2 -D onto a new line.
- tick the Enable AutoPerform box if it isn't already ticked.
- Save this change!
(AutoPerform tab is where you write helpy used-every-day commands like /join #absolutewrite so they execute automatically upon signing in)

In Chatzilla, select ChatZilla > Preferences
- select the connected server
- select the Lists tab
- select the Add button
- type umode2 -D (without the leading / )
- click on Apply button
- click on OK button
(Lists tab is where you add helpy used-every-day commands like join #absolutewrite so they execute automatically upon signing in)

Thanks to 10trackers for finding the fix.

-Derek
 
Last edited:

Jason

Ideas bounce around in my head
Super Member
Registered
Joined
Oct 26, 2016
Messages
5,932
Reaction score
999
Location
Nashville, TN
That reminds me - I've not been on the IRC chat in ages!
 

10trackers

Pollyanna, Shedder of Casual Blood
Kind Benefactor
Super Member
Registered
Joined
Feb 7, 2010
Messages
5,472
Reaction score
2,415
Location
not here, I swear
Edit: I tried adding the /umode2 -D string to IceChat's Settings > Startup tab so it would run automatically, and ticked the "Auto Perform on Startup" box, but this did not work, dammit. I still had to enter the string manually after starting IceChat.


HILARIOUSLY, it did work in my IceChat, same version as Derek's. Ahh, the wonders of information technology.
 

Happy Thanksgiving

Autumn image for Thanksgiving