PDA

View Full Version : Comments Trouble in Word



mkcbunny
05-19-2006, 08:04 AM
I realize that this isn't a grammar question, but as it's a technical thing, and especially since reph probably has the answer, I thought I could post it here. I'm sorry if my question should be elsewhere. It could have been in the Novel forum, but, then, it could really go anywhere....

I'm using comments in Word. Recently, I've discovered that some of the deleted comments haven't gone away. They do not appear in the body of the document, but when you open the "Comments" window, some of the ones I deleted in the body still show in numerical order. So, f'rinstance, the first comment that shows in my doc is #3, but when I open comments, there are two "dead" comments listed before that. I can't seem to delete them through the numerical Comments window.

Also, I've successfully deleted other comments after I noticed this problem. But I can't fix the ones that are an issue.

I hope that makes sense. Help, anyone?

Medievalist
05-19-2006, 08:20 AM
I realize that this isn't a grammar question, but as it's a technical thing, and especially since reph probably has the answer, I thought I could post it here. I'm sorry if my question should be elsewhere. It could have been in the Novel forum, but, then, it could really go anywhere....

I'm using comments in Word. Recently, I've discovered that some of the deleted comments haven't gone away. They do not appear in the body of the document, but when you open the "Comments" window, some of the ones I deleted in the body still show in numerical order. So, f'rinstance, the first comment that shows in my doc is #3, but when I open comments, there are two "dead" comments listed before that. I can't seem to delete them through the numerical Comments window.

Also, I've successfully deleted other comments after I noticed this problem. But I can't fix the ones that are an issue.

I hope that makes sense. Help, anyone?

Go to Preferences (or Options, depending on which version of Word you have) and make sure that you have Fast Save turned OFF. Fast Save is located either under General or under the Open/Save tab.

Try saving a new copy of the file using Save As.

mkcbunny
05-19-2006, 08:30 AM
Fast Save is off. Saved As doc has the same problem. Thanks, though.

Medievalist
05-19-2006, 08:37 AM
Fast Save is off. Saved As doc has the same problem. Thanks, though.

Have you tried using the Reviewing Toolbar?

Make sure the Reviewing Toolbar is showing
Find the anchor text for the comment you want to delete
Place the cursor in the anchor text, and click
Go to the Reviewing Toolbar
To the right of the New Comment button is a small triangle indicating a pop-menu
Click the triangle
Choose Delete Comment

reph
05-19-2006, 09:09 AM
Got news for you: I don't use Word.

Maybe you were thinking "Reph has all the answers about words."

Maybe my head is getting too big for the rest of me.

mkcbunny
05-19-2006, 09:50 AM
Have you tried using the Reviewing Toolbar?

Make sure the Reviewing Toolbar is showing
Find the anchor text for the comment you want to delete
Place the cursor in the anchor text, and click
Go to the Reviewing Toolbar
To the right of the New Comment button is a small triangle indicating a pop-menu
Click the triangle
Choose Delete Comment
Well, this was very helpful in that the Reviewing Toolbar is useful. However, when I locate the area where the ghost comment lives [I can't see it in the body of the text, but when I toggle through "Previous Comment" and "Next Comment" in the Toolbar, I can find where it was once], the "Delete Comment" icon fades out and does not allow me that option.

mkcbunny
05-19-2006, 09:52 AM
Got news for you: I don't use Word.
Well I won't ask why not, because I often wonder why I do....


Maybe you were thinking "Reph has all the answers about words."
Something like that, yeah.


Maybe my head is getting too big for the rest of me.
LOL.

unthoughtknown
05-19-2006, 09:57 AM
Well, this was very helpful in that the Reviewing Toolbar is useful. However, when I locate the area where the ghost comment lives [I can't see it in the body of the text, but when I toggle through "Previous Comment" and "Next Comment" in the Toolbar, I can find where it was once], the "Delete Comment" icon fades out and does not allow me that option.

If it's what I think you mean, in the reviewing toolbar, use your arrow keys to select where the field once was (it should highlight itself in grey when you've hit the spot) and that's when you delete it once and for all!

Does that work?

Medievalist
05-19-2006, 10:14 AM
Well, if nothing else works, you have a couple of options.

Geeky Option Use Reveal Formatting to hand delete the "tags" and the text for the ghost comments.

If You Do This WOrk on A Copy Of The File.

Second Option:

When you're finished with the other comments, Go to Save As and Save as .rtf.

Then open the file, and save again as MSWord.

mkcbunny
05-19-2006, 10:33 AM
If it's what I think you mean, in the reviewing toolbar, use your arrow keys to select where the field once was (it should highlight itself in grey when you've hit the spot) and that's when you delete it once and for all!

Does that work?
I can find the spot where it was, but there's no delete option when I am there. In the Reviewing Toolbar, the icon for "Delete Comment" iss still inactive.

I am on Mac, so my Word may look different from others'. But I presume PC users have a Delete icon, too.

unthoughtknown
05-19-2006, 10:37 AM
I can find the spot where it was, but there's no delete option when I am there. In the Reviewing Toolbar, the icon for "Delete Comment" iss still inactive.

I am on Mac, so my Word may look different from others'. But I presume PC users have a Delete icon, too.

Sorry, I meant DEL key on keyboard. Does it let you delete it that way?

mkcbunny
05-19-2006, 10:43 AM
Well, if nothing else works, you have a couple of options.

Geeky Option Use Reveal Formatting to hand delete the "tags" and the text for the ghost comments.

If You Do This WOrk on A Copy Of The File.
I'm moderately geeky and couldn't figure this out.


Second Option:

When you're finished with the other comments, Go to Save As and Save as .rtf.

Then open the file, and save again as MSWord.
This was an interesting suggestion. On the one hand, it worked. I was able to get rid of the comments. On the other, all of my changes came to the fore, even though I don't have them tracked. When it converted to rtf, every single change I'd ever made was visible as though I'd been tracking them all along. And when I converted to Word, they remained visible. Weird. Anyway, I might be able to monkey with this option, though it's a little shocking to see years of changes surface out of nowhere.

Thanks.

mkcbunny
05-19-2006, 10:46 AM
Sorry, I meant DEL key on keyboard. Does it let you delete it that way?
No. Well, it did when it worked. I have been doing it that way just fine for months. But then I realize tonight that some of the comments I deleted that way were still in the "Edit Comments" list. When I try to highlight-delete, I can cut a whole sentence and re-type it, but the comment stays in the "Edit Comments" list anyway. Even though the "offending" text is now long gone.

unthoughtknown
05-19-2006, 10:56 AM
That's quite weird! I wonder if your document is under quite a bit of stress...? ;-)

Sorry that I can't suggest anything else...

mkcbunny
05-19-2006, 11:04 AM
That's quite weird! I wonder if your document is under quite a bit of stress...? ;-)

It's the first half of my novel. 160 pages. It's been through a lot. Seeing all those tracked changes was horrifying ... and also a little encouraging, as it showed how much work I have done. I'm doing a line edit on it so I can [gasp!] give it to someone else [finally!]. My first official draft.

Anyway, I've been deleting my many comments as I address them, so it was discomfiting to find that they still lived. It seems such a simple thing to fix ... yet not so ...

unthoughtknown
05-19-2006, 11:09 AM
It's the first half of my novel. 160 pages. It's been through a lot. Seeing all those tracked changes was horrifying ... and also a little encouraging, as it showed how much work I have done. I'm doing a line edit on it so I can [gasp!] give it to someone else [finally!]. My first official draft.

Anyway, I've been deleting my many comments as I address them, so it was discomfiting to find that they still lived. It seems such a simple thing to fix ... yet not so ...

Well done, and good luck with it! I'm still quarter-way through my first draft. I was using COMMENTS during my first attempt at my novel but now I use the track changes feature instead. I turn TRACK on, make a comment and then turn TRACK off. It's easier to manage for me.

mkcbunny
05-19-2006, 11:15 AM
Well done, and good luck with it! I'm still quarter-way through my first draft. I was using COMMENTS during my first attempt at my novel but now I use the track changes feature instead. I turn TRACK on, make a comment and then turn TRACK off. It's easier to manage for me.
Thanks.

mkcbunny
05-19-2006, 11:54 PM
Oh boy, do I feel stupid. How long have I been using Word? How long did I work as a full-time editor? I'll spare myself the embarrassment of answering those questions for you kind people.

It was Medievalist's suggestion to convert to rtf that revealed to me the error of my ways, as follows:

All this time, my changes have been tracked and I never went into "Track Changes" to accept them. It never even occurred to me, as I've only ever addressed the Track Changes function when sending/editing docs with other people. So here I am, in my first enormous document, not thinking about the tracking of changes one bit. Needless to say, this is my first novel. Every other document I ever laid hands on professionally was under 10 pages, and the tracking was a given.

Well, I'm sure you can picture it now: Thousands of changes tracked, including deleted comments. Once I accepted all my changes, the deleted comments disappeared. Now, I can't explain why some of the excised comments remained on the Edit Comments list while others did not. I might have caught the problem sooner if the trouble had been consistent. But I've now fixed those pesky comments, and, more importantly, I'm sure I've cut down the size of my gigantic file by accepting all those changes.

Thank you all for your help. I might never have figured out the answer, nor the serious underlying problem, without your assistance.

Humbly yours,
mkc
[slinks off under a rock]

Medievalist
05-20-2006, 12:57 AM
I kind of wondered . . . if Fast Save is On, stuff will be retained, no matter what, but in RTF people can usually see the text itself and then, if it's there in RTF, I know that it's a Tracking issue.

Same thing is true of the Reveal Formatting -- the tags themselves, that indicated the tracking data, are visible.

Glad you figured it out, and good luck.