PDA

View Full Version : Setting up a Bi, Tri, Quad, (Ad Nauseum) lingual keyboard. (Windows)



Bartholomew
07-16-2010, 01:38 PM
This is a quick tutorial for setting up another language on your keyboard, so that you can participate in this sub-forum without messing with a character map, or sacrificing critical non-English characters.

Step One: Click on the Start Button on your Start Bar.

Step Two: Click Control Panel

Step Three: In Windows 7, click the Clock, Language, and Region link. In older versions, you'll find a Language and Region icon.

Step Four: In the Region and Language window, select the Keyboards and Languages tab.

Step Five: There should be a button labeled "Change Keyboards." Click this. We're going to make it so that you can switch your keyboard between several languages with a simple key-stroke. This will allow you to quickly switch between several languages.

Step Six: The next window will have a large white space that probably says "English (United States)" or "English (United Kingdoms)." Find the box to its right that says "Add." Clicky clicky.

Step Seven: You are now presented with a vast array of languages. Select whichever one you'd like to type in. (If it isn't present, a google search for "Windows (your version) (language name) Language Pack" will probably lead you in the right direction.) Once you've added the languages you want, go the Advanced Key Settings tab on the previous window.

Step Eight: In the white window, under "Action," find and select "Between Input Languages" and select "Change Key Sequence." A dialogue box will appear, offering you several hot-key options. I personally use Shift + Left Alt.

ADDED BONUS!

Switching languages inside an MS Word document will also change MS Word's default dictionary, allowing spell check to underline individual words, rather than your entire friggen Spanish short-story. X_X

SaraP
07-16-2010, 11:13 PM
Thanks much!

*puts on her work hat and adds some super-glue to the back of the thread*

Fenika
07-17-2010, 12:46 AM
Oh, I needed you two weeks ago when I was switching z and y and couldn't find any of the right symbols on my grandmother's keyboard!

Not sure if you covered it, but when changing languages in the task bar, it may keep changing back between programs. So you can have Skype in Czech and Firefox in English and your brain in Befuddleyish. :) Something to watch out for if you are having trouble.

Liosse de Velishaf
07-17-2010, 01:30 AM
Nice, Bart. :)

Bartholomew
07-17-2010, 05:04 AM
Oh, I needed you two weeks ago when I was switching z and y and couldn't find any of the right symbols on my grandmother's keyboard!

Not sure if you covered it, but when changing languages in the task bar, it may keep changing back between programs. So you can have Skype in Czech and Firefox in English and your brain in Befuddleyish. :) Something to watch out for if you are having trouble.

It will, yes. When I first learned I could change my keyboard's language, I managed to confuse the heck out of myself. I reformatted my system because I thought something had gone corrupt. About 1/2 way through reformatting, one of my friends helpfully poked her head in and said, "Oh, about that keyboard thing, by the way..."

It's funny, but only in retrospect.

Bookewyrme
07-17-2010, 07:57 AM
Awesome!
Now we just need this for Mac users. I've been trying to switch mine for six months to no avail. T_T

Liosse de Velishaf
07-18-2010, 09:52 AM
Awesome!
Now we just need this for Mac users. I've been trying to switch mine for six months to no avail. T_T


Can't you just go to System Preferences and then Language and Text/International and then Input Sources and then select the langauge you want to use and then pick the Show Input in Menubar option. There should be a flag for whatever country the language is from.

shawkins
07-18-2010, 11:41 PM
Great thread. Unfortunately, I ran into a problem. It turns out that versions of Vista below Ultimate don't support Japanese (or most other languages, apparently). If you have a similar problem and are comfortable with Linux, there's a pretty easy solution that works in OpenOffice.

yum install scim-anthy

Thereafter, <shift>+<space> in openoffice will give you non-english input options.

This document (http://www.h4.dion.ne.jp/~apricots/scim-anthy/howto.html) was really handy.

SCIM (smart common input method) is a generic support system for other character sets. scim-anthy is specific to japanese, but there are other scim-whatever packages available. I don't believe SCIM support is available for OpenOffice running on windows.

Liosse de Velishaf
07-19-2010, 12:23 AM
I'm sorry, but I have Home Premium, and it most certainly does support Japanese.

Bartholomew
07-19-2010, 04:06 AM
Great thread. Unfortunately, I ran into a problem. It turns out that versions of Vista below Ultimate don't support Japanese (or most other languages, apparently).

Sounds like you need to hunt down the language packs. You can get them through Windows Update.

Liosse de Velishaf
07-19-2010, 05:33 AM
http://support.microsoft.com/kb/935791

shawkins
07-19-2010, 05:36 PM
< shrug > You guys can't all be wrong. I'll take another look.

Bartholomew
07-19-2010, 05:48 PM
< shrug > You guys can't all be wrong. I'll take another look.

We could. This is Vista we're talking about.

Bookewyrme
07-23-2010, 05:20 AM
Can't you just go to System Preferences and then Language and Text/International and then Input Sources and then select the langauge you want to use and then pick the Show Input in Menubar option. There should be a flag for whatever country the language is from.

Yes, but I still can't type in any language except English. I can't seem to get either MSWord or TextEdit to recognize an Arabic font, and it is driving me bananas, because I have half a dozen different arabic fonts which came standard on my Mac, but I can't type in them. Or any other non-latinate font I might want to use for that matter. Anyway, this was not something I'd done so far, so thanks for that suggestion, even though it still doesn't work. Maybe I'm one step closer. *sigh*

Liosse de Velishaf
07-23-2010, 05:43 AM
Do you mean you picked the correct input language and then it just typed gibberish?

Bookewyrme
07-23-2010, 07:08 AM
Do you mean you picked the correct input language and then it just typed gibberish?

No, I mean I did that and all I got was still English. But, I have since figured out what the problem is, and can now type in my chosen language (I wasn't changing the little flag in the top bar. Durr.)

Anyway.
شكرا كثير :D
Now, I just have to learn where all the letters are on my US keyboard and remember which letters translate into which other letters. Seriously though, I could dance right now.

SaraP
07-23-2010, 07:09 AM
*does little happy dance for Booke* :D

Liosse de Velishaf
07-24-2010, 05:33 AM
Great thread idea, Bart.

Bartholomew
07-24-2010, 06:38 AM
^-^

branchwag
08-10-2010, 12:08 AM
I can't seem to get my computer to switch to Chinese. I went through the steps (I have Windows 7) and I have the Chinese mode selected (it shows up in my taskbar), but everything I type is still in English. ;( What happened? Do I need to install anything?

I use Firefox by the way. Is it the browser?

Bartholomew
08-15-2010, 12:37 PM
I can't seem to get my computer to switch to Chinese. I went through the steps (I have Windows 7) and I have the Chinese mode selected (it shows up in my taskbar), but everything I type is still in English. ;( What happened? Do I need to install anything?

I use Firefox by the way. Is it the browser?

Every program will default to English - so if you set it to Chinese with MS Word open, and then switch to AbsoluteWrite, you'll need to change the language to Chinese again.

Let me play with it and I'll see if I can find out what's wrong, tho.

Bartholomew
08-15-2010, 12:49 PM


.

:)

Ok, I figured it out.

When you're selecting Chinese under Text Services and Input Language, you're not just selecting Chinese, you're selecting which input method for the Chinese language you want.

I had the best luck with Pinyin New Experience and  Microsoft Pinyin ABC Input Style.

The others were unwieldy.

Andrea_James
02-27-2012, 01:28 AM
Whoa! I've been typing my German without umlauts for half the year I've been living here, and it's that easy to switch!?

merry_and_silver
01-16-2013, 06:24 AM
In Linux, "setxkbmap es" at the prompt sets my keyboard to Spanish, and "setxkbmap us" sets it back to English. There are many other (like dozens, I just looked) two-letter language codes that can be chosen. It's easy to make buttons to click between the different languages on the desktop.